STATIC Routes
Objective
Understanding the Operation of Static Routes. Static Routes are administratively defined routes that specify the address or interface of the next hop in the path that packets must take while moving between a source & destination.
Diagram
Procedure
- Configuring & Assigning the IP addresses on the routers R1 & R2.
- Check the routing table on both the routers.
- Administratively define the Static Routes on both routers so that hosts on the both routers can communicate with each other.
- Check the routing table on both the routers after defining the Static Routes on both sides.
- Verifying the connection of both hosts.
Configuration
Step 1(A): Assigning the IP addresses on the Router R1.
R1(config)#interface serial 0
R1(config-if)#ip address 15.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#clock rate 64000 (Clock Rate will set only DCE Interface)
R1(config-if)#exit
R1(config)#interface ethernet 0
R1(config-if)#ip address 10.0.0.20 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#end
Step 1(B): Assigning the IP addresses on the Router R2.
R2(config)#interface serial 0
R2(config-if)#ip address 15.0.0.2 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#end
R2(config)#interface ethernet 0
R2(config-if)#ip address 20.0.0.2 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#end
Step 2(A): Check the Routing table of the Router R1.
RA#sh ip route
C 10.0.0.0/8 is directly connected, Ethernet0
C 15.0.0.0/8 is directly connected, Serial0
Step 2(B): Check the Routing table of the Router R2.
RB#sh ip route
C 20.0.0.0/8 is directly connected, Ethernet0
C 15.0.0.0/8 is directly connected, Serial0
Step 3(A): Administratively define the Static Route on the Router R1.
RA(config)#ip route 20.0.0.0 255.0.0.0 15.0.0.2 (Desired destination networks)
Step 3(B): Administratively define the Static Route on the Router R2.
RB(config)#ip route 10.0.0.0 255.0.0.0 15.0.0.1 (Desired destination networks)
Step 4(A): Check the Routing table of the Router R2 after enabling RIP.
RA#sh ip route
S 20.0.0.0/8 [1/0] via 15.0.0.2
C 10.0.0.0/8 is directly connected, Ethernet0
C 15.0.0.0/8 is directly connected, Serial0
Step 5(B): Check the Routing table of the Router R2 after enabling RIP.
RB#sh ip route
C 20.0.0.0/8 is directly connected, Ethernet0
S 10.0.0.0/8 [1/0] via 15.0.0.1
C 15.0.0.0/8 is directly connected, Serial0
Step 5: Verifying the connection of Host ‘A’ & Host ‘B’.
C:\>ping 20.0.0.1
Pinging 20.0.0.1 with 32 bytes of data:
Reply from 20.0.0.1: bytes=32 time=20ms TTL=254
Reply from 20.0.0.1: bytes=32 time=20ms TTL=254
Reply from 20.0.0.1: bytes=32 time=10ms TTL=254
Reply from 20.0.0.1: bytes=32 time=10ms TTL=254
Ping statistics for 20.0.0.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 10ms, Maximum = 20ms, Average = 15ms
No comments:
Post a Comment